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Come connettere TNT Express a ShippyPro

Vediamo come connettere TNT Express a ShippyPro in pochi passaggi. 🔍

 

 

1. Prima di iniziare

Per connettere TNT Express devi chiedere le tue credenziali TNT Connect al tuo Account Manager TNT: Account Number, Account Country (2 digits), Production Username, Production Password

 

2. Servizi supportati

Servizi disponibili:

  • ​ALL SERVICES

  • EXPRESS - 15

  • EXPRESS - 15N

  • 09:00 EXPRESS - 09

  • 10:00 EXPRESS - 10

  • 12:00 EXPRESS - 12

  • 12:00 EXPRESS - 12N

  • ECONOMY EXPRESS - 48N

  • 12:00 ECONOMY EXPRESS - 412


⚠️Per usare le live rates, dovrai selezionare “All Services”

Attenzione: TNT Express può attualmente essere utilizzato solo per le Spedizioni nazionali.

 

3. Opzioni aggiuntive

Oltre alle tue credenziali, vedrai anche ulteriori opzioni, vediamole insieme!

 

  • Tipo Etichetta ti dĂ  la possibilitĂ  di scegliere il formato di etichetta corretto per la tua stampante.

    📌 Il formato suggerito per le etichette TNT Express è PDF A6, è possibile impostarlo da Corrieri facendo click su Modifica.

  • Genera borderò ti dĂ  la possibilitĂ  di generare per ogni spedizione un borderò insieme all'etichetta
  • Cut off time (XX:XX format) si riferisce all'Orario di Ritiro che devi verificare direttamente con il Corriere.

    Se viene visualizzato “If the collection date is today, preferred collection end time must be greater than now + 1 hour”, significa che hai provato a creare l'etichetta un'ora prima dell'Orario di Ritiro.

 

4. Errori & Risoluzioni

 

Ricorda che la trasmissione delle tariffe per TNT Express è automatica. Per questo motivo, in presenza dell'errore sopra è necessario verificare che le credenziali inserite siano corrette.

 

Di seguito alcuni errori comuni che potrebbero aiutarti nella verifica:

 

  • L'username non può essere un indirizzo mail, per questo motivo è necessario richiederlo al tuo referente TNT Express insieme alla password.

  • E' necessario inserire il Paese legato all'account in formato sigla, e quindi in massimo due lettere.

Es. è necessario che il Regno Unito sia inserito come GB.

 

Non è inoltre possibile aggiungere più di un Paese:

 

​
​

9400 Contact: name has exceeded it's maximum length
La lunghezza di questo campo non deve superare 22 caratteri.
​
​4003 Delivery address: name has exceeded its maximum length
La lunghezza di questo campo non deve superare i 30 caratteri.

 

Non ci sono aggiornamenti del tracciamento per la spedizione

Bisogna essere sicuri che la cittĂ  di destinazione immessa sia corretta e congrua con la nomenclatura di TNT, altrimenti il corriere non riesce a fornirci le informazioni di tracciamento.

 

The delivery address town could not be found
Questo errore significa che la combinazione cittĂ  e codice postale fornita non corrisponde allo stradario di TNT. Puoi contattare il tuo ReferenteTNT per ulteriore assistenza.

 

The shipment date cannot be more than 14 days in the future.

Controlla l'opzione corriere CollectionDate e assicurati di selezionare una data precedente.

 

There must be one hour difference between preferred collection times

Inserisci un lasso di tempo di almeno 1 ora nell'opzione corriere "collection time from" e "collection time to".

 

Error 500 - Internal Server Error

L'Error 500 indica che il server di TNT Express ha riscontrato una condizione imprevista durante l'elaborazione della tua richiesta. Si tratta di un problema lato server sull'infrastruttura di TNT, non un problema con i tuoi dati o la configurazione dell'integrazione.

Possibili cause

  • Manutenzione del server o deployment in corso
  • Un bug o un'eccezione non gestita nell'API di TNT
  • Problemi di connettivitĂ  al database lato TNT
  • Sovraccarico del server o degrado delle prestazioni
  • Problemi di configurazione o connettivitĂ  sull'infrastruttura di TNT

Soluzioni consigliate

Segui questi passaggi per risolvere il problema:

  • Verifica le credenziali del corriere — Controlla che le tue credenziali TNT Express (API key, numero account, username/password) siano corrette e attive su ShippyPro. Credenziali scadute o errate possono a volte generare errori del server.
  • Riprova la richiesta — Attendi 2-5 minuti e riprova la richiesta. Questi errori sono spesso temporanei.